Download NetNewsWire 3.3.2

3.3.2 requires Mac OS X 10.6, and runs on 10.7 and 10.8.

Download NetNewsWire 3.2.15

3.2.15 is the final version to support PowerPC Macs and OS X 10.5.8.